Skip to content

Hello!

Hello!

{
  "about_me": {
    "name": "David Pena",
    "current-role": "Tech Support Engineer",
    "current-career-focus": "Cybersecurity Engineer"
  }
}
SCROLL TO EXPLORE

security · cloud · python · ai

DAVID
PENA

Building at the intersection of cybersecurity, cloud, Python, and AI.

Cybersecurity-focused Technical Support Engineer building hands-on projects in threat hunting, identity, cloud security, and AI-assisted security automation.

SCROLL TO EXPLORE

01 / CURRENT FOCUS

Currently Building

AI + SECURITY

Agentic SOC Analyst

An AI-powered threat hunting assistant that translates natural-language security questions into KQL, queries Microsoft Defender / Azure Log Analytics telemetry, and analyzes results to accelerate investigations.

Python KQL Azure Microsoft Defender Log Analytics LLM
Live Demo → GitHub →

USER

Has windows-target-1 had suspicious logons in the last 72 hours?

AGENT

Querying DeviceLogonEvents...

KQL

DeviceLogonEvents
| where DeviceName == "windows-target-1"
| where Timestamp > ago(72h)
| where ActionType == "LogonFailed" or IsExternalIp == true
| project Timestamp, AccountName, RemoteIP, ActionType

02 / SELECTED WORK

Projects

03 / STACK

Technologies I Work With

04 / CERTIFICATIONS

Certifications

View All on LinkedIn →

05 / RESUME

Resume

Download PDF →
David Pena's GitHub avatar

Building in public.

@Darideivi

View GitHub Profile →

06 / CONTACT

Let's build something secure.

Interested in cybersecurity, cloud security, AI-assisted security engineering, or threat hunting? Let's connect.